White Cube of Death – Compiz Fusion

http://wiki.compiz-fusion.org/Troubleshooting#head-e5535bd303a9db6a704d8de087bb9f6a2958c1f0

Beim Betrieb von Compiz-Fusion unter KDE und einer NVIDIA Karte kann es zum „White Cube of Death“ Problem kommen.

White Cube of Death
White Cube of Death

Dabei kommt es beim Start von KDE kurz zu den erwünschten Desktopmodifikationen durch Compiz. Aber nach kurzem wird alles weiß, man kann immernoch die Maus bewegen (sieht man anhand des Wechsels des Mauszeigers wenn er über ein Icon kommt), sogar den Cube rotieren lassen, aber es bleibt alles weiß.

WcoD zu Beginn:

White Cube of Death in senien Anfängen
White Cube of Death in senien Anfängen

WcoD nach wenigen Sekunden:

White Cube of Death nach ein paar Sekunden
White Cube of Death nach ein paar Sekunden

Die angebliche Lösung gibts hier auf Englisch, Quelle ist oben. (Recherchiert für einen Bekannten, selbe Problem unter ATI, leider wurde es nur begrenzt behoben (nu sind keine Fensterrahmen mehr da)

A workaround is to log in with a different session (e.g. Window Maker or FVWM) which does not use Compiz, then start kcontrol, go to KDE Components -> Session Manager and select „Start with an empty session“. Now Compiz should work without problems. If you cannot log in and start kcontrol, log in at a text console and remove the KDE Session configuration file with the following command:

rm ~/.kde/share/config/ksmserverrc

It seems that the bug is created by an entry in ~/.kde/share/config/ksmserverrc reading something like:

program1=
restartCommand1=compiz,–replace,gconf,decoration

In unserem Spezialfall von KANOTIX 2007 Thorhammer hat das leider nicht geholfen. Gelöst wurde das Problem dennoch auf folgendem Wege:

Nach einer Neuinstallation des ATI Treibers (nicht mit kanos script aus dem hause kanotix sondern direkt von debian „install-fglrx-debian.sh“ und dem setzten einiger flags beim Initial gings dann doch:

LIBGL_ALWAYS_INDIRECT=1 INTEL_BATCH=1 compiz –replace –indirect-rendering –sm-disable ccp &

Quelle:

http://wiki.compiz-fusion.org/Troubleshooting

Funktionierender Cube nach Bugfix
Funktionierender Cube nach Bugfix

Die Eckdaten des Testsystemes:

  • Host/Kernel/OS „thinkpad“ running Linux 2.6.26-4-generic i686 [ KANOTIX 2007 Thorhammer ]
  • CPU Info Intel Celeron M clocked at [ 1595.404 MHz ]
  • Videocard ATI RC410 [Radeon Xpress 200M]
  • X.Org 7.1.1 [ 1024×768 @60hz ]
  • Processes 117 | Uptime 5:43 | Memory 259.4/438.0MB | HDD Size 60GB (12%used) | GLX Renderer ATI Radeon Xpress Series | GLX Version 2.1.7537 Release | Client Shell | Infobash v2.67.1

PS: n Cube kann jeder haben ….

Rund ist schöner
Rund ist schöner

Ähnliche Artikel:

Beryl unter Debian Etch

Nachdem ich mir auf meinem Standrechner Debian Etch installiert hatte, um von jeglichen Versuchungen (Spielen) abgelenkt zu sein und für die Uni zu werken, begann ich mit Linux zu spielen. Da muss natürlich der Cube her. Also flott mal nach Informationen gegoogelt inwiefern Beryl bereits unter Debian zum laufen gebracht wurde.

Nachdem ich mir auf meinem Standrechner Debian Etch installiert hatte, um von jeglichen Versuchungen (Spielen) abgelenkt zu sein und für die Uni zu werken, begann ich mit Linux zu spielen. Da muss natürlich der Cube her. Also flott mal nach Informationen gegoogelt inwiefern Beryl bereits unter Debian zum laufen gebracht wurde.
Folgender Link hat mir dahingehend alle Informationen geliefert die ich brauchte und noch ein paar mehr. Natürlich hat am Schluss nicht meine NVIDIA geglänzt sondern meine ATI :P

lunapark6 und debian

I was half way there but I still needed to install Beryl. The procedure was pretty easy. I had to first add two new repositories to my /etc/apt/sources.list :

deb http://debian.beryl-project.org/ etch main
deb-src http://debian.beryl-project.org/ etch main

then in the terminal install the gpg key for that repository via :

wget -O – http://debian.beryl-project.org/root@lupine.me.uk.gpg | sudo apt-key add –

after that :

su –
apt-get install beryl-manager emerald-themes

Beryl was installed but I had to manually edit the xorg.conf to make it work with the Nvidia drivers. Basically I did :

su –
nano /etc/X11/xorg.conf

then added these two lines under the “Screen” section :

Option „XAANoOffscreenPixmaps“
Option „AddARGBGLXVisuals“ „true“

then added these lines under “Device” :

Option „AllowGLXWithComposite“ „true“
Option „RenderAccel“ „true“

added one line under “Server Layout” :

Option “AIGLX” „on“

Finally at the end of the file I added these lines :

Section „Extensions“
Option „Composite“ „Enable“
EndSection

With a reboot, beryl and nvidia were doing its magic.

Ähnliche Artikel: