quakelive with some problems on linux (libpng newer than 1.2)

Unfortunately there are some problems displaying the graphic of quakelive when using libpng newer than 1.2. Within the last weeks my archlinux offerd me to update it to 1.4. Afterwards quakelive was broken. It displayed only some artefakts where icons or text was before.

Quake Live broken visualization
Screenshot was taken from: http://www.quakelive.com/forum/showthread.php?&t=43859

To fix this problem there is a simple workaround:

  1. Check if libpng12.so exist ( ls -lha /usr/lib/libpng12.so )
  2. Install libpng 1.2 (on arch e.g. yaourt -S libpng12 )
  3. Start firefox using this command: LD_PRELOAD=“/usr/lib/libpng12.so“ /usr/bin/firefox

For more comfort a i wrote myself an alias by editing .bashrc and adding this line:

alias quakelive="LD_PRELOAD=/usr/lib/libpng12.so /urs/bin/firefox"

by the next login the alias will be available and if you wish you can add an shortcut to your startmanu or panel etc.

usagehint: if an instance of firefox is already running you have to stop it first

Ähnliche Artikel: